云黑系统对接说明

一、初衷

起初,这个项目仅仅是供给我们内部使用,并未想过对外开放或者盈利,其作用就是使我们远离一些“网络键盘侠”以及“骗子”并起到警示作用,但是后来此网站被搜索引擎收录后有很多人私信我要进行对接,所以在这里我把对接方法放出来。

二、对接

接口API链接:https://yh.qqrobot.ltd/query.php?qq=

“qq”后面直接加上QQ号码或者频道ID即可返回查询结果。

等级越高程度越严重,最高三级。

小栗子框架对接BOT易语言例程:

.版本 2

.子程序 查询云黑, 文本型
.参数 发送者, 文本型
.局部变量 返回, 文本型

返回 = 编码_utf8到gb2312 (网页_访问S (“https://yh.qqrobot.ltd/query.php?qq=” + 发送者, , , , , , , , , , , , , , , , , , , , ))
云黑.云黑级别 = 文本_取出中间文本 (返回, “黑名单级别:”, “级”, , )
云黑.云黑原因 = 文本_取右边 (返回, “黑名单原因:”, , )
云黑.云黑时间 = 文本_取出中间文本 (返回, “黑名单时间:”, “<br>黑名单原因”, , )
云黑.云黑ID = 文本_取出中间文本 (返回, “查询QQ/ID:”, “<br>黑名单级”, , )
返回 (云黑.云黑级别)

.子程序 用户权限, 整数型
.参数 QQ, 文本型

.如果真 (寻找文本 (读配置项 (应用目录 + “admin.ini”, “admin”, “administrator”, ), QQ, , 假) ≠ -1)
返回 (1)
.如果真结束
返回 (0)

 

三、其他

注意,上面的方法是针对有编程基础的用户来进行对接使用,仅支持逐个查询,不可批量导出。因为成本原因,我们暂不开放免费查询BOT,感谢理解。

本文标题:云黑系统对接说明
本文作者:zyq
本文链接:https://zyq.today/archives/95804
版权声明:本站采用 BY-NC-SA 进行许可。转载请注明出处!
暂无评论

发送评论 编辑评论


|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
😍
😘
😜
😝
😏
😒
🙄
😳
😔
😫
😱
😭
😶
🌚
😣
🤨
😣
🤐
😪
🤤
🥵
🤮
😨
😱
😓
🤬
👴
🤡
🙈
💊
🙏
🤺
💩
👻
🙌
🖕
👍
👫
👌
🙏
👀
🐒
🔪
UID: 503262632
颜文字
Emoji
小恐龙
Mirror
amashiro.natsuki
genshin
上一篇
下一篇